Error with Angular Compiler / ng-packagr

I am fairly new to bit and want to upload my component. I have done this before and everything worked fine.

So the first issue is: I run

bit import bit.envs/angular -c

Then I get a message :

  • bit.envs/angular@0.1.9 [deprecated]

Which is concerning but okay it still works.

When I run bit tag --all or try to tag any component I get this error:

Command failed: node /Users/freshprojects/dev/shared_components_bit/.git/bit/components/angular/bit.envs/0.1.9/node_modules/ng-packagr/cli/main.js -p ng-package.json -c tsconfig.json
error TS6046: Argument for ‘–lib’ option must be: ‘es5’, ‘es6’, ‘es2015’, ‘es7’, ‘es2016’, ‘es2017’, ‘es2018’, ‘es2019’, ‘esnext’, ‘dom’, ‘dom.iterable’, ‘webworker’, ‘webworker.importscripts’, ‘scripthost’, ‘es2015.core’, ‘es2015.collection’, ‘es2015.generator’, ‘es2015.iterable’, ‘es2015.promise’, ‘es2015.proxy’, ‘es2015.reflect’, ‘es2015.symbol’, ‘es2015.symbol.wellknown’, ‘es2016.array.include’, ‘es2017.object’, ‘es2017.sharedmemory’, ‘es2017.string’, ‘es2017.intl’, ‘es2017.typedarrays’, ‘es2018.asynciterable’, ‘es2018.intl’, ‘es2018.promise’, ‘es2018.regexp’, ‘es2019.array’, ‘es2019.string’, ‘es2019.symbol’, ‘esnext.array’, ‘esnext.symbol’, ‘esnext.asynciterable’, ‘esnext.intl’, ‘esnext.bigint’.

Building Angular Package

Angular Version:
@angular-devkit/architect 0.803.20
@angular-devkit/core 8.3.20
@angular-devkit/schematics 8.3.20
@schematics/angular 8.3.20
@schematics/update 0.803.20
rxjs 6.4.0

Any idea what the issue could be? bit doctor passes all the checks.

@Vaaljan did you manage to fix this. I have the same issue.