Angular compiler installs a unsupported typescript version

When building Angular components with the Angular compiler (version 9.0.14) I get the following error message:

Screen Shot 2020-06-02 at 12.32.29

If I look at the Angular compiler page, under dependencies, the typescript version is set to 3.8.3. Why is the not working 3.9.3 version being installed?

I tried to install the other 9.0.x versions as well, unfortunately with the same result.

Is there a way to use a different typescript version for the Angular compiler?